GLSL Shaders 1.16.1/1.15.2/1.14.4 (Karyonix) Mod for Minecraft

GLSL Shaders Mod 1.9.4

GLSL Shaders is a modification for Minecraft 1.16.1/1.15.2/1.14.4 that brings OpenGL based Shader graphics in your Minecraft world and make it look fabulous. It enables a lot of effects such as improved shadows, better lighting and connected textures by utilizing the power of your PCIe Graphic card. GLSL shaders is often used with Sonic Ether’s Unbelievable Shaders to maximize the visual effects of shaders in Minecraft.

Advertisement

GLSL Shaders Features:

  • Supports HD resource/texture packs.
  • Support multiple composite programs (compostire1, composite2, composite3)
  • Shader packs such SEUS, MAC Shaders, Bump Shadow waving are supported
  • Minecraft Forge and OptiFine Compatibility
  • Easy installation without any hassle
Download GLSL Shaders for Minecraft:

For Minecraft 1.12:

For Minecraft 1.11.2:

For Minecraft 1.10.2:

For Minecraft 1.10:

For Minecraft 1.9.4:

For Minecraft 1.9:

GLSL Shaders Download

For 1.8

This version is compatible with Forge Build 1487 and supports OptiFine 1.8.0 HD Ultra D5

For 1.7.10 [Optifine]

by karyonix/daxnitro – Last updated 27th August, 2015

GLSL Shaders Demo

How to install GLSL Shaders in Minecraft

This guide is for Minecraft 1.16/1.15.2/1.14.4/1.13.2/1.12.2.

  • Download and install the latest build of Minecraft Forge API. Run the game once after that.
  • Then Download and install the OptiFine HD according to your game version. OptiFine installation is optional but it improves FPS greatly.
  • Now download GLSL shaders Mod jar file from link mentioned above.
  • Open Start Menu > type %appdata/.minecraft/mods and press Enter.
  • Move the Shaders mod jar file to the mods folder.
  • Download SEUS shaderpacks zip file according to your preference. Do not extract it
  • Start Minecraft > Go to options > Shaders > Open Shaderpacks folder and put the zip file there.
  • Now select the SEUS v10.1 shaders from Shaders list, it will take a moment to load depending on your computer’s speed.
  • Now create a new world and enjoy the improved graphics!

This guide is intended for Minecraft version 1.5.2 and below.

  • You need to download and install specific OptiFine HD  version as mentioned in download link above.
  • Go to Start Menu > Type %appdata%/.minecraft/bin and press Enter
  • Open minecraft.jar in WinRAR or 7-Zip or similar program.
  • Delete META-INF in minecraft.jar.
  • If you use Forge, copy files from Forge universal zip into minecraft.jar
  • Copy files from OptiFine zip into minecraft.jar.
  • Copy files from ShadersMod zip into minecraft.jar
  • Close minecraft.jar file and run the game.  Test it without shaderpack first.
  • If the game cannot run, you may have to restore minecraft.jar from backup and try again or give up.
  • Go to Options > Shaders > Open shaderpacks folder.
  • Put Sonic Ether’s Unbelievable Shaders v10 zip file in there.
  • Go back to Minecraft Shaders GUI.  Click Shaderpack name from the list and Enjoy

Tips and Warnings:

  • Make sure you have above average graphic card and RAM on your PC. For e.g. Nvidia GeForce GTX 460 with 4GB RAM or better. Intel core i3, i5 or i7 4th generation processors are recommended.
  • Mac OS will give compatibility issues due to lack of proper OpenGL support
  • Update your ATI or nVidia WHQL video card drivers to the latest. This is very important.
  • Magic Launcher can be used for installation.

60 Comments

  • I’m not sure if this file is actually updated. The file still has 1.4.6 in its name.

    Reply
  • optifine d5 ultra doesn’t works with minecraft 1.5!
    optifine a2 ultra is for minecraft 1.5, is the GLSL shaders works with that?

    Reply
  • WRONG! Does not work with 1.5.1, you’ll have to wait until it actually comes out 🙁

    Reply
  • Not 1.5.1 compatible, only Optifine A7 Ultra works with 1.5.1 & GLSL Shaders only currently work with D5 ultra for 1.4.7 etc

    Reply
  • dont work for me i dont see options> shaders in minercraft menu

    Thanks.

    Reply
  • Why do you say “1.5.1” in the title if it doesn’t works with this version ?!?!
    Do you think it’s a funny joke ? Or is it a ridiculous way to make traffic on this site ?
    I tried so many links for this mod or Sonic Ether’s one. They all claims working for 1.5 in the title, bu this is false !!!
    Why ?
    I understand that a mod could be long/hard to program, but it’s not a reason to write false things an make many people angry by trying without succes.

    Reply
    • Hey, it’s isn’t for 1.5.1!

      See the file:
      “For OptiFine D5 Ultra: ShadersMod-mc1.4.6-ofuD5-1.43.zip”
      ^ ^

      It’s only a way to make traffic on this site, but they will update in the future.

      Search the official topic of the mod:
      “GLSL SHADERS MOD MODIFIED BY KARYONIX”

      Reply
  • This didnt work for me…. this better not be a troll or I will be VERY mad.

    Reply
  • if You Guys keep telling Black screen your just so nooby and lazy because Black Screen Is META data thats Attacking your Minecraft you guys Need To remove All The META – Data or you will never get it work just don’t be so lazy k? Guys?

    Reply
  • finaly i find a clear answer, i delete meta file and install apropriately, the optifine works just fine but once i add what you told me to add… i get black screen. and yes i double checked the meta folder is deleted! please remove 1.5.1 from your title….if there isnt a new mod for it

    Reply
  • Ther IS a link for 1.5.1, minecraft forums topic, page 68, near the bottom.

    Reply
    • But that is the beta version of the mod and not compatible with newest OptiFine. So in short, you’re going to have a lot of problems when you install it.

      I do not post unstable mods here.

      Reply
  • well I can’t get this to work for 1.5.2
    the problem is they require D2U version of optifine
    however in optifine 1.5.2 the only D2 is D2L
    the others are D3S and D3U

    it would be nice if they could ‘link’ to the correct version
    and yes i’ve tried D3U incase the D2U was a typo, i even tried D3S

    help?

    Reply
  • =======================================
    DOWNLOAD 1.5.2 D2U HERE!
    I searched over the net for the right version and i found one
    +++++++++++++++++++++++++++++++++++++++
    https://www.dropbox.com/s/kcsovruppmsxe7c/OptiFine_1.5.2_HD_U_D2.zip
    =======================================
    Thank you, Sorry for Caps.

    this should help anyone who’s having issues finding the right version

    hopes this gets updated

    Reply
  • I installed it correcly but i got black screen when i start minecraft :I

    Please help.

    Reply
  • I can’t find “shaders” in options for the life of me. Perhaps they tossed it in 1.6?

    Reply
  • I don’t find Optifine D3U… Is it D2U? Because D3U doesn’t exist 🙁

    Reply
  • Will you please update to 1.6?Me and so much more people would REALLY love it!

    Reply
  • When is the release date for 1.6 version of the pack?

    I’m starting a new series and I need this mod ASAP!

    Reply
  • Help I keep crashing and my minecraft 1.6.2 consul says something like no openGl = false or something like that HELP

    Reply
    • more specific info: My GPU is not compatible with the shaders mod how do I fix

      Reply
    • It isn’t lag you idiot. You have a shitty pc which is why you are experiencing FPS drop. Lag is when you experience events after other players on a multiplayer server because of a bad internet connection and it has nothing to do with FPS.

      Reply
      • well server lag has nothing to do with fps, but when people have bad fps they commonly refer to it as “lag” which is obviously what he was saying. so he was right

        Reply
  • Hey, I installed it all correctly, with optifine, and without the GLSL Shaders mod it works fine, but with it my minecraft crashes instantly. Anybody else experiencing this problem?

    Reply
  • Hey. i have install’t shaders and optifine (forge) om my minecraft, but when i try to start it, it crash. I have a craft rapport, where should i put it.

    Reply
  • When I open minecraft after i added shaders and then i go inta options it doesnt pop up

    Reply
  • omg im using this site forever it works soo good i would give this site a GIGANTIC THUMBS UP

    Reply
  • I love this mod so much because it makes my Minecraft looks more realistic, but can you update to 1.7.2/1.7.4 plz ?

    Reply
  • what do i do if my screen blinks black and the dirt backround?

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *