GLSL Shaders (Karyonix) for Minecraft 1.7.10/1.7.2/1.6.4

advertisement

GLSL Shaders for MinecraftGLSL Shaders is a modification for Minecraft 1.7.10/1.7.2/1.6.4 that brings OpenGL based Shader graphics in your Minecraft world and make it look fabulous. It enables a lot of effects such as improved shadows, better lighting and connected textures by utilizing the power of your PCIe Graphic card. GLSL shaders is often used with Sonic Ether’s Unbelievable Shaders to maximize the visual effects of shaders in Minecraft.

GLSL Shaders Features:

  • Supports HD resource/texture packs.
  • Support multiple composite programs (compostire1, composite2, composite3)
  • Shader packs such SEUS, MAC Shaders, Bump Shadow waving are supported
  • Minecraft Forge and OptiFine Compatibility
  • Easy installation without any hassle

GLSL Shaders DownloadDownload GLSL Shaders for Minecraft:

For 1.7.5 

For 1.7.2 and 1.7.10 (Forge/OptiFine compatible)

For 1.6.4 OptiFine C8U

Optifine Anisotropic filtering and anti-aliasing are not yet supported, disable them.

For 1.5.2 OptiFine D3U

by karyonix/daxnitro – Last updated 28th June, 2014

GLSL Shaders Demo

How to install GLSL Shaders in Minecraft

This guide is for Minecraft 1.7.10, 1.7.2 and 1.6.4.

  • Download and install the latest build of Minecraft Forge API. Run the game once after that.
  • Then Download and install the OptiFine HD version as mentioned in GLSL Shaders jar file. OptiFine installation is optional but it improves FPS greatly.
  • Now download GLSL shaders Mod jar file from link mentioned above.
  • Open Start Menu > type %appdata/.minecraft/mods and press Enter.
  • Move the Shaders mod jar file to the mods folder.
  • Download SEUS shaderpacks zip file according to your preference. Do not extract it
  • Start Minecraft > Go to options > Shaders > Open Shaderpacks folder and put the zip file there.
  • Now select the SEUS v10.1 shaders from Shaders list, it will take a moment to load depending on your computer’s speed.
  • Now create a new world and enjoy the improved graphics!

This guide is intended for Minecraft version 1.5.2 and below.

  • You need to download and install specific OptiFine HD  version as mentioned in download link above.
  • Go to Start Menu > Type %appdata%/.minecraft/bin and press Enter
  • Open minecraft.jar in WinRAR or 7-Zip or similar program.
  • Delete META-INF in minecraft.jar.
  • If you use Forge, copy files from Forge universal zip into minecraft.jar
  • Copy files from OptiFine zip into minecraft.jar.
  • Copy files from ShadersMod zip into minecraft.jar
  • Close minecraft.jar file and run the game.  Test it without shaderpack first.
  • If the game cannot run, you may have to restore minecraft.jar from backup and try again or give up.
  • Go to Options > Shaders > Open shaderpacks folder.
  • Put Sonic Ether’s Unbelievable Shaders v10 zip file in there.
  • Go back to Minecraft Shaders GUI.  Click Shaderpack name from the list and Enjoy

Tips and Warnings:

  • Make sure you have above average graphic card and RAM on your PC. For e.g. Nvidia GeForce GTX 460 with 4GB RAM or better. Intel core i3, i5 or i7 4th generation processors are recommended.
  • Mac OS will give compatibility issues due to lack of proper OpenGL support
  • Update your ATI or Nvidia video card drivers to the latest. This is very important.
  • Magic Launcher can be used for installation.

62 thoughts on “GLSL Shaders (Karyonix) for Minecraft 1.7.10/1.7.2/1.6.4

  1. optifine d5 ultra doesn’t works with minecraft 1.5!
    optifine a2 ultra is for minecraft 1.5, is the GLSL shaders works with that?

  2. Not 1.5.1 compatible, only Optifine A7 Ultra works with 1.5.1 & GLSL Shaders only currently work with D5 ultra for 1.4.7 etc

  3. Why do you say “1.5.1″ in the title if it doesn’t works with this version ?!?!
    Do you think it’s a funny joke ? Or is it a ridiculous way to make traffic on this site ?
    I tried so many links for this mod or Sonic Ether’s one. They all claims working for 1.5 in the title, bu this is false !!!
    Why ?
    I understand that a mod could be long/hard to program, but it’s not a reason to write false things an make many people angry by trying without succes.

    • Hey, it’s isn’t for 1.5.1!

      See the file:
      “For OptiFine D5 Ultra: ShadersMod-mc1.4.6-ofuD5-1.43.zip”
      ^ ^

      It’s only a way to make traffic on this site, but they will update in the future.

      Search the official topic of the mod:
      “GLSL SHADERS MOD MODIFIED BY KARYONIX”

  4. if You Guys keep telling Black screen your just so nooby and lazy because Black Screen Is META data thats Attacking your Minecraft you guys Need To remove All The META – Data or you will never get it work just don’t be so lazy k? Guys?

  5. finaly i find a clear answer, i delete meta file and install apropriately, the optifine works just fine but once i add what you told me to add… i get black screen. and yes i double checked the meta folder is deleted! please remove 1.5.1 from your title….if there isnt a new mod for it

    • But that is the beta version of the mod and not compatible with newest OptiFine. So in short, you’re going to have a lot of problems when you install it.

      I do not post unstable mods here.

  6. well I can’t get this to work for 1.5.2
    the problem is they require D2U version of optifine
    however in optifine 1.5.2 the only D2 is D2L
    the others are D3S and D3U

    it would be nice if they could ‘link’ to the correct version
    and yes i’ve tried D3U incase the D2U was a typo, i even tried D3S

    help?

    • It isn’t lag you idiot. You have a shitty pc which is why you are experiencing FPS drop. Lag is when you experience events after other players on a multiplayer server because of a bad internet connection and it has nothing to do with FPS.

      • well server lag has nothing to do with fps, but when people have bad fps they commonly refer to it as “lag” which is obviously what he was saying. so he was right

  7. Hey, I installed it all correctly, with optifine, and without the GLSL Shaders mod it works fine, but with it my minecraft crashes instantly. Anybody else experiencing this problem?

  8. Hey. i have install’t shaders and optifine (forge) om my minecraft, but when i try to start it, it crash. I have a craft rapport, where should i put it.

  9. Protip: If you have more than 2GB RAM, install 64-bit Java (alongside your 32-bit Java, unless the only Web browser you use is a 64-bit mod of Firefox or Chrome) and set your launcher to use it (usually just means taking ” (x86)” out of the folder path) with -Xmx8G (change 8 to 50-75% of your RAM size in gigabytes). This should improve performance and let you use higher settings without OutOfMemoryError crashes.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>